[Solved] Web pages show nothing, but calls to WCF service are working.

Jan 15, 2014 at 7:32 PM
Edited Jan 15, 2014 at 8:05 PM
This is a screenshot of minimal.htm. You can see that the calls are going out to the web service, but nothing is showing up in the page.

see: http://imgur.com/UCRTVXY

If I browse to the service following the same query that the page uses, we can see that presence information is indeed being returned.

see: http://imgur.com/JGB1OPY

Any ideas? I haven't even gotten to trying to initiate a chat session yet. Still stuck on presence.

I was having the same problem with index.htm, but decided to use minimal.htm to reduce points of potential failure. Viewing index.htm just results in the empty boxes.
Jan 15, 2014 at 8:17 PM
Edited Jan 15, 2014 at 8:45 PM
I see that my presence query result is missing some prefix data that the OrbitOne demo is getting:


Is the demo still using the same code?
Jan 15, 2014 at 11:08 PM
Edited Jan 15, 2014 at 11:09 PM
So i gave up on presence. I got chat.htm to send a message to an internal user, but then the web page throws up on itself with ajax/jquery errors. I'm going home.
Jan 16, 2014 at 3:46 PM
Edited Jan 16, 2014 at 3:49 PM
Everything is my fault. I was running the WCF services against a 2.0 app pool instead of a 4.0. In the process of troubleshooting, the references to .NET 3.5 in the web.config had me thinking to switch to 2.0 and since it semi worked, I was troubleshooting in all the wrong areas.

I can now vouch for the Lync Presence and Chat widget to be working in a 2010 application pool in a Lync 2013 environment.