Troubleshooting presence widget with NO errors

Sep 7, 2012 at 5:24 PM

I am attempting to deploy the Presence widget on Windows 2008 R2. I compiled the solution with Build. Then deployed with Build Deployment Package. I made sure that in the project properties under Application the target version was .NET 3.5. Once compiled I imported the application to IIS using the deply .cmd script. I then made sure to run application pool as 32 bit applications to false to avoid the SIPEPS error, and removed Microsoft.Rtc.Internal.Media DLL to avoid errors with it.

When a browse to the Service.svc it gives not errors. I am acecssing via http since I had a cert issue. I also tried running the minimal.htm page configured to point to orbitone service and it simply showed me a black page. I also tried the index.htm page pointing to the same service, and the local SamplePictures folder. Does not show anything. The application pool is configure with 2.0 since on IIS 3.5 is not availble. (Correct me if im wrong). .NEt Ajax support was also installed. Also the Service.svc does not log. Should a Lync client be installed? Or is this included in Lync core installation step.

Any pointers will help. Thanks in advance. 

Sep 8, 2012 at 2:10 AM

Okay. Never mind. So I ended up correcting myself. Set app pool to 4.0, and just compile the project with .NET 3.5 as target. This began to give me errors which ultimately get presence working but the chatting is now giving me the following error: Unable to perform authentication of credentials

Any clues? 

Note that this did not fix the issue : Disable Idle timeout (in minutes) on the application pool. This can be disabled by setting it to 0.