UserService.svc

Mar 17, 2014 at 8:02 AM
when I try to build solution with visual studio I get error:

The type or namespace name 'UserService' does not exist in the namespace 'Lync.Widget.Library' (are you missing an assembly reference?)


Any one can help me solving this issue,

Thanks in Advance
Mar 17, 2014 at 11:23 AM
rabee2002 wrote:
when I try to build solution with visual studio I get error:

The type or namespace name 'UserService' does not exist in the namespace 'Lync.Widget.Library' (are you missing an assembly reference?)


Any one can help me solving this issue,

Thanks in Advance
I have same problem..
Mar 21, 2014 at 10:19 PM
I also have the same problem.

UserService seems to be a reference to an external web service, but the URL is just given as http://****/UserService.svc, but no hint as to what this is or where to get it from.
Jun 11, 2014 at 3:45 PM
I am also getting the same error. Is the UserService in a different repository?
Jun 12, 2014 at 2:49 PM
Edited Jun 12, 2014 at 2:49 PM
the lync userservice needs to be deployed on your dev machine: first deploy it on local iis, reference the WS in the VS and the class UserService will be generated
(and also this service needs to be deployed on prod env)
Jun 18, 2014 at 7:14 PM
What feature in the topology needs to be enabled for the UserServices application to be enabled?
Jun 18, 2014 at 9:04 PM
Edited Jun 18, 2014 at 9:05 PM
Where is the code for the Lync UserService? It is not included with the source code.
Jul 17, 2014 at 10:18 AM
rikhelsen wrote:
the lync userservice needs to be deployed on your dev machine: first deploy it on local iis, reference the WS in the VS and the class UserService will be generated
(and also this service needs to be deployed on prod env)
where can we get userservice?